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KaleidaGraph Quick Start Guide

This document is a hands-on guide that walks you through the use of KaleidaGraph. You will probably w
print this guide and then start your exploration of the product. If you have any questions or problems, ple
contact technical support.

Please also refer to the ReadMe file which provides installation instructions, details on getting help, and 
more.
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Getting Started

This guide contains four major examples to guide you through the operation of KaleidaGraph. We recom
that you try and complete all four at one sitting, however you can save the files and finish the tour at a la
time.

These examples will show you how to do the following:

•   Create a new data set, change the column titles and format, sort the data, and calculate simple statist
the data.

•   Create and modify a Scatter plot of the data from the first example. This example shows how to chang
display of the variable, use of a few plot tools, and add a curve fit and error bars.

•   Create a Column plot from a saved data set. This example shows how to modify the axes, change the
of the axis labels, and add value labels above the columns.
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•   Display the plots from the preceding examples on the same page using the layout window.

Some optional examples are also included in this guide to show you how to perform common operations
covered in the main examples. The topics include editing the legend text and frame, using Formula Entry
applying a user-defined curve fit, and modifying data in a saved plot.

A section on generating similar plots is also included to give you hints on how to maintain a consistent lo
the plots that you create.

At this point, you are ready to start learning KaleidaGraph.

Example 1 - Generating a Sample Data Set

This example takes you through the process of typing data into the data window, changing the column ti
format, sorting the data, and calculating statistics on the raw data.

•   Start KaleidaGraph by double-clicking the KaleidaGraph icon.

When you launch KaleidaGraph there will be two windows displayed: an empty data window and a Form
Entry window. The data window is a speadsheet used to enter and store data for plotting and analysis. B
default, new data windows are created with 10 columns and 100 rows. Each data window can contain a 
maximum of 1000 columns and 1 million rows.

The first step is to type some data into the data window. To do this:

•   Type 4.3 into the first cell of column 0.

•   Press the Enter (Windows), Return (Macintosh), or Down Arrow  key to move down to the next cell.

•   Type the values 2.9, 4.8, 3.2, 3.9, 3.5, and 2.3 into column 0. After each value is entered, press the Enter, 
Return, or Down Arrow  key to move down a row.

•   Click the cell at row 0, column 1.

•   Use the same method to type the data values 8.0, 6.2, 9.0, 5.7, 8.8, 7.2, and 4.9 into column 1.

Next we will change the titles and format for these two columns.

•   Double-click the column title of column 0 (or choose Data > Column Format).

This will display the Column Format dialog. This dialog displays the names of the data columns to the le
contains a field below the listing where you can edit the names of the columns.

•   Type Time into the field below the listing of column titles.

•   Click the name of the second column (B).
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•   Type Test 1 into the field below the listing of column titles.

This dialog can also be used to change the format of the data columns.  The steps that follow will chang
display of the data so that each value only has one decimal place.

•   Press Shift and click both the Time and Test 1 entries. 

•   From the Format pop-up menu, choose Fixed.

•   From the Decimals pop-up menu, choose 1.

•   Click OK  to apply the changes to the data window.

Your data window should resemble the one shown in Figure 1.

Figure 1

Now we will sort the data to get the values in ascending order (from low to high).

•   If it is not already selected, click the Time label in the data window to select the entire column.

•   Choose Functions > Ascending Sort.

•   Press Shift and click both the Time and Test 1 entries. 

•   Click OK  to apply the changes to the data window.

The final step will be to calculate a number of standard statistics on one of the data columns.

•   Click the Test 1 label in the data window to select the entire column.

•   Choose Functions > Statistics.
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A dialog will be displayed showing the calculated values for each of 10 different statistics. This dialog pro
a Copy to Clipboard button to export the results for use in a data, plot, or layout window.

•   Click OK .

At this point, you can proceed to the next example or save your data by choosing File > Save Data.

Example 2 - Creating a Scatter Plot with Linear Curve Fit and Error Bars

This example uses the data from the preceding example to create a Scatter plot. This example shows ho
change marker type, size and color, use the Identify and Data Selection tools, apply a Linear curve fit, di
the curve fit equation, and add error bars.

Now, let's create a plot using the example data entered in the previous exercise.

•   Choose Gallery > Linear  > Line.

This will display the Variable Selection dialog. Notice that the name of the data file and its column titles a
displayed in this dialog.

•   Select Time as the X variable and Test 1 as the Y variable by clicking the appropriate buttons.

Figure 2 shows what your Variable Selection dialog should look like at this point.

Figure 2
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•   Click New Plot to create a Scatter plot.

The X variable you selected is the independent variable and the Y variable is the dependent variable.  B
default, the X variable is plotted on the horizontal axis and the Y variable is plotted on the vertical axis.

The title of the plot is taken from the name of the data window.  The X and Y axis titles are taken from th
column titles of the variables being plotted.  The Y variable title is also used in the legend.

Now that the graph has been created, it can be modified very easily. For example, let's change how the 
represented on the plot. You will use the Plot Style dialog to change the marker type, size, and color.

•   Triple-click the marker displayed in the legend (or choose Plot > Plot Style).

•   Select a different marker to represent the variable on the plot.

The markers are displayed on the left side of the dialog. The first six markers in the left column are trans
all of the others are opaque.

•   Change the value in the Marker Size field to 18 and select a different color from the color palette.

•   Click OK  and the plot will be redrawn to reflect the changes that have been made.

Now we will use the Identify tool from the toolbox to display the coordinates of the data. The Identify tool
looks like a set of crosshairs.

•   Select the Identify tool by either clicking it or pressing I  on your keyboard.

•   Once the tool is selected, click one of the data points. The X and Y coordinates are displayed in the up
corner of the plot window.

It is also possible to leave the coordinates directly on the plot.  To do this:

•   Press Alt  (Windows) or Option (Macintosh) as you release the mouse button. This will place a label 
containing the coordinates to the right of the point.

You can quickly and easily fit a curve to a set of data points. To add a curve fit to the plot:

•   Choose Curve Fit > Linear . This will display a dialog to select which variables to fit with the Least Squa
Error method.

•   Select a variable to be fit (in this case Test 1) by clicking its check box.

•   Click OK . The curve fit is calculated and the curve fit line is drawn on the plot. By default, the curve fit
results will also be displayed on the plot. If the equation is not displayed, turn on Display Equation in the Plot 
menu.
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The position of the equation can be changed using the Selection Arrow.

•   Click the Selection Arrow on the toolbox.

•   Drag the equation to a new position.

•   When the move is complete, click anywhere else in the window and the object handles will disappear

•   You can use the same technique to move the legend.

At this point, your plot should resemble Figure 3.

Figure 3

Once a curve fit is applied, you can copy the values of the curve fit line to the data window. These value
appended after the existing data in your data window. The first column will be a series of X values. The n
of X values will be equal to the number of curve fit points specified in the Curve Fit Options dialog (Format 
menu). The second column will contain the values from the curve fit at each of these locations.

•   Reselect Linear  from the Curve Fit menu. A Curve Fit Selections dialog appears with a drop-down arrow
under View.

•   Click the drop-down arrow and choose Copy Curve Fit to Data Window from the pop-up menu.

•   Click OK  to return to the plot window.

Now we will use the Data Selection tool to graphically remove a point from the plot. The Data Selection t
located below the Identify tool in the toolbox.

•   Select the Data Selection tool by either clicking it or pressing S on your keyboard.
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The Data Selection tool operates by enclosing a region of the plot in a polygon. Any data points outside 
polygon are removed from the plot. By pressing Alt  (Windows) or Option (Macintosh) as you make the 
polygon, you can eliminate the data inside of the polygon.

•   Once the tool is selected, press Alt  (Windows) or Option (Macintosh) and create a polygon around the dat
point in the lower-left corner of the plot window. Once the polygon is complete, the point will be removed
the curve fit will be recalculated.

•   Double-click the Data Selection tool to return the plot to its original state.

The last modification to the plot will be the addition of error bars. Error bars illustrate the amount of error
the plotted data.

•   Choose Plot > Error Bars  to display the Error Bar Variables dialog.

•   Click the check box in the Y Err  column to add vertical error bars. A dialog will be displayed so you can
choose the type of error to be used.

•   From the pop-up menu, choose Standard Error  for the error type.

Both of the pop-up menus will have Standard Error selected because the Link Error Bars  check box is 
selected. Otherwise, it would be possible to have the error bar display one type of error for the positive p
of the bar and a different error (or no error at all) for the negative portion.

Your Error Bar dialog should look like the one in Figure 4.

Figure 4
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•   Click OK  and you will return to the Error Bar dialog.

•   Click Plot and error bars will be added to the plot. The error bars represent the standard error of the e
data column.

The finished plot is shown in Figure 5.

Figure 5

You have just created a customized plot. You can continue on to the next example or you can save the p
choosing File > Save Graph. If you save the graph, a copy of the data window will be saved with the plot (
the same file). The process of opening a saved plot and extracting the data is covered in one of the optio
examples later in this guide.

Example 3 - Creating a Column Plot with Value Labels

This example uses a Column plot to show how to adjust major and minor ticks, axis labels, fill patterns, c
spacing, plot color, label rotation, and display values above the columns.

We will begin this example by opening a saved data set.

•   Choose File > Open.

•   Locate and open the Data folder, which is located in the Examples folder.

•   Double-click the Housing Starts file.

This will open the file in a new data window. Notice that the data in the column titled Month  is left justified. 
This is because it contains text, not numbers. When a text column is used as the X axis variable (in a Co
plot), you can have up to 300 labels and an unlimited number of rows (categories) plotted.
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Now, let’s create a plot using this data.

•   Choose Gallery > Bar > Column. The Variable Selection dialog is displayed.

•   Select Month  as the X variable and 1966(K) as the Y variable by clicking the appropriate buttons.

•   Click New Plot to create a Column plot.

The first set of changes will be made in the Axis Options dialog. This dialog contains the majority of the 
settings for the axes, grid lines, tick marks, and axis labels.

•   Triple-click the X axis (or choose Plot > Axis Options). This will display the dialog in Figure 6.

Figure 6

The first change will be to remove the vertical grid lines.

•   Click Grids. The dialog will change to show the options that can be selected for the major and minor g

•   Choose None from the pop-up menu to the right of Major .

The next change will be to remove the tick marks on the X axis.

•   Click Ticks. The dialog will change to show the options that can be selected for the major and minor ti

•   Choose None from the pop-up menus below both Major  and Minor .

The next change also involves the tick marks, but this time on the Y axis.

•   Select the Y axis from the pop-up menu under Axis.
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•   Choose Out from the pop-up menus below both Major  and Minor .

The last step is to change the maximum Y axis limit from 140 to 160.

•   Click Limits . The dialog will change to show the options that can be selected for the limits.

•   Change the value in the Max field from 140 to 160.

•   Click OK  to have the plot updated.

Now you can change the fill pattern for the columns using the Plot Style dialog.

•   Triple-click the small square in the legend which is filled with the same pattern as the columns (or cho
Plot > Plot Style).

•   You can now choose a different fill pattern for the columns. Click one of the fill patterns and a frame w
appear around that pattern to show that it is selected.

•   Click OK .

The next step will be to increase the amount of space between the columns.

•   Choose Format > Plot Extras.

•   Change the Column Offset percentage from 20 to 40%.

•   Click OK  to update the plot.

At this point, your plot should resemble the one shown in Figure 7.

Figure 7
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The next step will be to add some color to the interior of the plot.  By default, plots are created without in
and background colors.  To select an interior color:

•   Click any of the four axes to select the plot.

Two sets of icons will be displayed at the bottom of the toolbox. The first icon displays two overlapping 
rectangles which control the interior and background color of the plot.

•   Click the rectangle in the foreground and select one of the lighter colors from the color palette that ap
The selected color will be used to fill the interior of the plot.

The following steps will show how to remove the X axis title, resize the Y axis title, and rotate the X axis 
labels.

•   Click the X axis title, Month , and press Backspace (Windows) or Delete (Macintosh).

•   Click the Y axis title, 1966 (K). Drag any one of the four object handles to increase the font size of the l
It is also possible to change the font size by double-clicking the text label.

•   Double-click one of the X axis labels. Notice that this dialog has its own set of menus.

•   Choose Format > 90 Degree Rotation.

•   Also choose Format > Right Justify so that the rotated labels will line up evenly.

•   Click OK  to get back to the plot window.

•   Drag one of the X axis labels closer to the axis. You can also use the arrow keys to move selected ob
pixel at a time in the specified direction (10 pixels if you press Shift while using the arrow keys).

The last step is to display the values of each column. To do this:

•   Turn on Add Values in the Plot menu.

The values are placed at the top of each column. The values can be moved as a group by dragging them
new location.

The Column plot is now complete.

Example 4 - Laying out Plots for Printing

This example shows how to use the layout window to place the plots created in the previous examples o
single page.

Note: The following steps assume the two plots from the previous examples are still available. If you had
the plots and quit before reaching this example, use the Open command (File menu) to open these plots. If you
do not have them any longer, you can open any two plots from the Plots folder in the Examples folder.
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•   Choose Windows > Show Layout > KG Layout . If no layout has been created previously, an empty layo
window will be displayed.

•   Use the Select Plot command (Layout menu) to select the two plots that were created in the previous 
examples. At this point, do not worry about their overall placement.

•   Choose Layout > Arrange Layout. The Arrange Layout dialog allows you to enter the number of rows a
columns to divide the layout window into equal sections.

•   The default settings (two rows and one column) are sufficient for this example, so click OK .

Notice that the layout window was divided into two equal sections and the plots were automatically resiz
placed into these sections.

It is possible to display more than just plots in the layout window. The plot tools are available, enabling y
add text and other objects to the layout. Various graphic images can be imported into the layout window
a background pattern and frame can be added to the layout using the Set Background command (Layout 
menu).

Feel free to print the layout by choosing File > Print Layout . The contents of the layout window can be copie
to the Clipboard using the Copy Layout command (Edit  menu). It is also possible to export the layout in a 
variety of formats using the appropriate command from the Export  submenu (File menu).

•   Close the layout window by choosing File > Close.

Where to Go from Here

We have just taken you on a pretty informative tour on the use of KaleidaGraph. At this point, you can be
experiment on your own or you may continue with some or all of the additional examples in the following
section. These examples cover some more specific topics than those you have just completed. If you ne
information on any of the commands you have used up to now, you can get more complete details in the
manual.

If you would like to quit for now, choose Exit  (Windows) or Quit  (Macintosh) from the File menu.
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Additional Examples

This section contains some optional examples to show you some of the finer points of KaleidaGraph. Un
major examples you completed earlier, you do not have to follow the additional examples in any order. Y
pick out those topics which are relevant to the way you will be using KaleidaGraph to get a greater feel f
program. These examples will show you how to do the following:

•   Edit the legend frame and text.

•   Use the Formula Entry window to perform calculations in the data window.

•   Apply a user-defined curve fit, display the resulting equation, and change the display of the curve fit li

•   Open a saved plot, display the original data, and, after making changes to the data, automatically upd
plot and curve fit.

A section on generating similar plots is also included after this section to give you hints on how to mainta
consistent look for the plots that you create.

Editing the Legend

This example shows how to edit the legend frame and text.

The attributes of the legend frame are controlled by the bottom three icons on the toolbox. Most of the ch
to the legend frame involve the last icon in the toolbox, which is divided into two sections: a Line Style ic
the left and a Line Width icon on the right. The steps below will use these two sections of the icon to mak
various changes.

•   Open the Sample Plot file which is located in the Plots folder in the Examples folder.

•   Click the legend to select it.

•   From the toolbox, click the Line Width icon (the up and down arrows) and choose Hairline  from the pop-up 
menu. Notice that the legend frame changes from a shadow box to a hairline width line.

•   Now click the Line Style icon (the one to the left of the up and down arrows) and select one of the das
lines from the pop-up menu. Notice that the line surrounding the legend now contains the dashed pattern
selected.

•   Finally, choose None from the Line Style pop-up menu. This removes the legend frame completely.

Now we can edit the text inside the legend.

•   Select the Text tool from the toolbox. This is the tool to the right of the Selection Arrow. You can selec
tool by either clicking it or pressing T on your keyboard.
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•   Double-click any of the three labels inside the legend. A dialog will be displayed that will let you modif
information.

•   Delete the text in this dialog and type any information you like. Feel free to change the font, size, and 
well.

•   Click OK  to return to the plot and see the change.

The changes you made only affect this one label.  If you use the Selection Arrow instead of the Text tool
can change the attributes of all legend items at once.  However, you cannot edit the text with the Selecti
Arrow.

Using Formula Entry

This example shows how to use the Formula Entry window, shown in Figure 8, to operate on the data w
Details on executing a multi-line formula are also included.

Figure 8

The Formula Entry window is a very powerful tool for data analysis. Use Formula Entry to enter equation
(functions) that generate and manipulate data in the frontmost data window. The results of a formula can
placed in a data column, a single cell, or a memory location.

Memory locations and column numbers can be used in formulas. Memory locations range from 0 to 99 a
need to be preceded by an m when used in a formula (m15, m35, and so on).

Column numbers range from 0 to 999 and need to be preceded by a c when used in a formula (c10, c55, and so
on). Column numbers are displayed in a box at the top of the column. Please note that when a selection
in the data window, the first column in the selection becomes column 0.

The following are a few examples of basic formulas along with a description of each:

    c2=c0+c1;    Adds the first two columns together and stores the results in column 2
    c1=c0/1000;    Divides column 0 by 1000 and stores the results in column 1
    c2=cos(c0);    Calculates the cosine of column 0 and stores the results in column 2
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Let’s get started by running a few formulas and seeing their effects on the data window:

•   Choose File > New to display an empty data window.

To execute a formula from the Formula Entry window, a data window must be open. Otherwise, the Run button 
is unavailable.

•   Choose Windows > Formula Entry .

By default the F1 function button will be selected. The F1-F8 buttons can be used to store common form
however we recommend that you leave F1 for general use and store your formulas in F2-F8.

Note: In the steps that follow, you can press Enter (Windows) or Return (Macintosh) instead of clicking Run.

•   Click F2, type c0=index() + 1, and click Run.

This creates a series from 1 to 100 in column 0.

•   Click F3, type c1=log(c0), and click Run.

This function calculates the logarithm of each value in column 0 and stores the results in column 1.

•   Click F4, type c2=c1^2, and click Run.

This formula squares each value in column 1 and stores the results in column 2.

•   Click F5, type cell(0,3)=csum(c2), and click Run.

This formula calculates the total sum of the values in column 2 and stores the result in the cell at row 0, 
3. You will need to click the right scroll arrow to see the result of this formula.

It is not necessary to enter and execute each formula individually. KaleidaGraph has a method to enter m
formulas and execute them all at once.

To the left of the F1 button is a Posted Note button. Clicking this button displays a text editor. You can e
multiple formulas into the editor and execute them all at once by clicking Run. The formulas must be on 
separate lines and each must be terminated with a semicolon.

Let’s try using the same formulas from before, but this time executing them using the Posted Note windo

•   Choose File > New to display an empty data window.

•   Choose Windows > Formula Entry .

•   Click the Posted Note button in the Formula Entry window to display a text editor. This button is locate
the left of the F1 button.
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•   Type the following formulas into the Posted Note window. Note that each formula ends with a semicol
appears on a separate line.

     c0=index() + 1;
     c1=log(c0);
     c2=c1^2;
     cell(0,3)=csum(c2);

•   After the formulas are entered, choose File > Exit  to return to the Formula Entry window. A message will b
displayed in the Formula Entry window telling you to click Run to execute the Formula Posted Note.

•   Click the Run button to execute all of the formulas at once.

As you can see, this is a very convenient method to execute multiple formulas at once.  Using this metho
can save the formulas as a text file from the Posted Note dialog that can be opened at a later time.

Applying a General (user-defined) Curve Fit

This example takes you through the process of defining and applying a user-defined curve fit. KaleidaGr
General curve fit is based on the Levenberg-Marquardt algorithm. You can solve up to nine unknown 
parameters during the fitting process.

We will start by creating a data set from scratch.

•   Choose File > New to display an empty data window.

•   Choose Windows > Formula Entry .

The Formula Entry window is used to analyze and manipulate data in the active (frontmost) data window
function you run will always operate on the active data window.

•   If it is not already selected, click F1.

•   Type c0=index()-50 into the Formula Entry window and click Run.

This will generate a unit series of -50 to 49 in the first data column (column 0). The index() command sim
returns the current row number each time the formula is executed.

•   Click F2, type c1=5+10*exp(-c0*c0/(20*20)), and click Run. The results will be placed in the second data
column (column 1).

Now let's create a Line plot of this data.

•   Choose Gallery > Linear  > Line.

•   Select A as the X variable and B as the Y variable.
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•   Click the New Plot button to create a Line plot.

Now we are ready to apply a General curve fit.  The first step in this process is to define the curve fit and
to the list of available General curve fits.

•   Choose Curve Fit > General > Edit General. This will display the dialog in Figure 9.

Figure 9

•   Click Add.

•   Click the New Fit that was added to the listing on the left side of the dialog. The name can be changed
field below the listing. Change the name to Gaussian.

•   Click Edit  to display the Curve Fit Definition dialog, shown in Figure 10, for the General curve fit. This 
where we will enter the curve fit definition.

Figure 10
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A Gaussian curve fit is of the form y=a+b*e^(-(x-c)^2/d^2). In KaleidaGraph, you should enter the equati
(using m0 as X and m1-m9 as your unknowns) with some initial guesses to give the algorithm a starting 
The format for adding initial guesses is to follow the equation with a semicolon and separate each initial 
with a semicolon.

•   Type m1+m2*exp(-(m0-m3)*(m0-m3)/(m4*m4));m1=1;m2=5;m3=1;m4=10 into the Curve Fit Definition 
dialog and click OK  to each dialog to return to the plot.

Now that the curve fit has been defined, it can be applied to the data.

•   Choose Curve Fit > General > Gaussian. This is the curve fit that we added in the previous set of steps.

•   In the dialog that appears, click the check box in front of B to apply the curve fit to this variable.

•   Click OK  and the curve fit will be calculated and displayed on the plot.

•   If the resulting equation is not displayed already, turn on Display Equation in the Plot menu to show a table 
containing the results of the fit.

The table lists the values of the unknown parameters along with the standard error of these values. It sh
read as the parameter value +/- the standard error. The Chi Square and R values are also displayed as 
curve fit results.

•   Turn off Display Equation to hide the table.

The final changes will be to increase the number of markers, hide the variable line, and change the color
line style of the curve fit line.

•   Triple-click the marker in the legend (or choose Plot > Plot Style).

•   From the Show Markers pop-up menu, choose Every 5th marker.

•   Select None from the Style column to hide the variable line.

•   Click Curve Fit. Now you can control the appearance of the curve fit line.

•   Select a different line style, line width, and color for the curve fit. Click OK  to apply the changes.

Modifying Data in a Saved Plot

This example shows how to modify a data point in a saved plot and have the plot and any curve fits 
automatically updated.

To get started, we need to open a saved plot and extract the data.  To do this:

•   Choose File > Open and open the Sample Plot file (located in the Plots folder, within the Examples folder).
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•   With the plot frontmost, choose Plot > Extract Data. The original data used to create the plot will be 
displayed.

The title of the window begins with the same name as the original data file.  Additionally, a time and date
is appended to the name, identifying when the data was archived in the plot.  The data is still linked to th
window, so nothing with regard to the curve fit, etc. has changed.

Now we can make changes to the data and have the plot updated.

•   Turn on Auto Link  in the Plot menu. When this command is active, you can make changes to the data 
have the plot automatically updated after each individual change.

•   Change the value in the first row of column 1 from 78.5 to 100.

•   Use one of the arrow keys to move to another cell to activate the Auto Link feature. The plot and curv
will automatically be updated to reflect the modified data value.

If you need to add or edit multiple data points, it may be more efficient to use the Update Plot command (Plot 
menu) because Auto Link causes the plot to update after each change. In this case, turn off Auto Link , make 
any changes to the data, and choose Update Plot. The plot will be updated to reflect all of the changes at onc

Generating Similar Plots

If you routinely create the same types of plots, it would be helpful to set up some defaults or templates s
most of the work could be done automatically. KaleidaGraph provides several features that can be used
generate similar plots.

This section discusses the use of Style files, Template plots, and Plot Scripts to achieve a consistent loo
your plots. The following will give you a general idea of when to use each:

•   Style files - This feature is useful for setting program defaults like font information, plot characteristics
colors, and so on. This information is used any time a new plot is created. It is possible to export separa
files so that you can load different settings as needed.

•   Template plots - This feature is useful when you have an existing plot and would like to replace the da
keeping the look of the plot intact. If the original plot contains curve fits or error bars, the resulting plot wi
also have these applied. The plot and axis titles will remain the same; however, the legend will reflect the
of the new variable.

•   Plot Scripts - This feature is useful when you need to generate several identical plots at one time from
different data sets. If the script is pointed at a plot that contains curve fits or error bars, each resulting plo
also have these applied. Other features include the option to automatically save or print each plot and th
to set the titles and legend information for each plot.
Page 19



log 
lot 
w to 

he 
end.

ettings 

ile when 
Style Files

One way to generate similar plots is through the use of Style files. KaleidaGraph stores most of your dia
settings and program defaults into a Style file. The Style file also stores layouts for each of the various p
types, in addition to any defaults you may have set for colors and text labels. This section will explain ho
define plot layouts and set defaults for text labels.

Each of the plots in the Gallery menu can have its own layout. The layout remembers the default style for t
legend, the position of the axis titles, plot title, axes, and legend, and the size of the axes, frame, and leg

To define the layout for a plot:

•   Create a plot of the type you want to define.

•   Modify the position and size of the titles, plot, and legend.

•   Choose Plot > Define Layout. A dialog appears, asking if you want to save the layout for this plot type.

•   Click OK  to save the layout.

Defining the layout of a plot only saves the position of the titles and legend.  It does not save any of the s
for the text labels.

To set defaults for text labels:

•   Choose Format > Text Options.

•   Click the labels for which you want to set new defaults. The different text labels are described below:
        -    Standard Labels - Axis titles and any text created with the Text tool.
        -    Legends - Any text that appears in the legend.
        -    Plot Titles - The text representing the plot’s title.
        -    Equation Labels - Text that appears when displaying the equation calculated by a curve fit.
        -    Value Labels - Text that appears when Add Values is turned on or text error bars are applied.
        -    X, Y, Y2, or X2 Axis Labels - The labels placed at major tick marks to display their value.
        -    Y2 Legend - Text that appears in the Y2 legend of a Double Y or Double XY plot.

•   Click OK . You will return to the plot window and any labels that had their attributes changed will be 
updated.

For these changes to be remembered the next time you launch KaleidaGraph, you must save the Style f
quitting. If you would like to create individual Style files for different projects, choose File > Export  > Style. 
This way you can save any number of different Style files which can be opened at a later time using the Open 
command.
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Template Plots

The Template plot is used to generate the same type of plot, using different data.  It allows you to take a
graph and use it as a base for plotting new data.  This works for both new graphs and graphs that have b
saved.

The new data will be autoscaled unless the limits are specified otherwise in the Axis Options dialog.  The
legend will reflect the new variables being plotted, but all other text labels and objects will remain the sam
the template.  Any curve fits or error bars on the original will be applied and recalculated on the new plot

Once a Template plot has been created, it can be modified in the same way as any other plot.  The limita
when using the Template plot is that only one plot can be generated at a time.  If you need the ability to g
multiple plots at once, use the Plot Script feature instead.

To use a plot as a template for creating other plots:

•   Open or create the plot you want to use as a base for creating other plots.

•   Choose Gallery > Template. A Variable Selection dialog will appear.

•   Click the appropriate buttons to select the variables to be plotted.

•   Click New Plot to generate a plot based on your selections.

It is not necessary to use the Template plot if you are only modifying the original data used to create the
Instead you can extract the data from the plot, modify it, and then update the plot. This process is covere
of the additional examples in this guide.

Plot Scripts

Another feature that allows you to generate similar plots is the Plot Script command in the Windows menu.  
This command enables you to select any plot type or an existing plot and use it as a template for creatin
plots.

Plot scripts are intended for the user who has a Template plot and wants to plot different data sets again
then save, print, or view the resulting curves. Even if you only need to generate a simple plot, but you ge
it all of the time with different data, you will find the Plot Script very useful.

The advantage of a script over a Template plot is that a script can generate, print, and save multiple plot
once. Also, a script allows you to control legend descriptions and plot titles. In a Template plot, the legen
descriptions come from the column titles of the new data and the plot title does not change.

To create a plot script:

•   Choose Windows > Plot Script to display a dialog which is used to make your selections for the current
script.
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•   If groups are already listed in this window, click Clear All . Then, click Yes to the dialog which asks if you 
want to delete the script. The groups will be removed and you are ready to create a script.

•   Use the Graphic Template pop-up menu to select a template plot. You can either select an existing plo
one is open) or one of the choices from the Gallery submenu. Only one template per script is allowed.

•   Click Add. A Variable Selection dialog will be displayed.

•   Select the variables to be plotted.

•   Click OK .  Group 1 will be listed in the Plot Script window.  Continue using the Add button to create new 
groups as needed.  Each group generates a separate plot.

•   When you are finished creating groups, click Run to execute the script.

The settings for the Plot Script window are saved as part of the KG Script file when quitting KaleidaGrap
an existing plot was selected as the template, a copy of this plot will be saved in the same directory as th
Script file.  Opening the script will automatically open the template plot.

Contact Information

If you have any questions concerning KaleidaGraph, please contact us at:

Synergy Software
2457 Perkiomen Avenue
Reading, PA 19606

Tel:  610-779-0522
Fax:  610-370-0548

Internet addresses:
Sales/Upgrades:  sales@synergy.com
Technical Support:  tech@synergy.com

Web Site:  www.kaleidagraph.com
                 www.synergy.com
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